<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" prefix="og: http://ogp.me/ns#">
<head profile="http://gmpg.org/xfn/11">
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta name="viewport" content="initial-scale=1.0, width=device-width" />
<meta property="og:image" content="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/branded/FB-Watermark.jpg" />
<meta name="apple-mobile-web-app-title" content="watermark">

<link rel="apple-touch-icon-precomposed" href="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/branded/FB-Watermark.jpg" " />

	<link rel="icon" type="image/png" href="http://www.watermarkonline.com/wp-content/uploads/site-icon-wmo-16px.png" />
    <title>Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt - Watermark Online</title>
	
	<link rel="stylesheet" href="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/style.css " type="text/css" media="all" />
	<link rel="pingback" href="http://www.watermarkonline.com/xmlrpc.php" />


    
	
<!-- This site is optimized with the Yoast SEO plugin v11.0 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.watermarkonline.com/2019/05/27/suspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt - Watermark Online" />
<meta property="og:description" content="BOISE, Idaho (AP) | Idaho police captured a man May 24 suspected of shooting and killing a motorist in northern Utah earlier this week after a two-day manhunt. Officers arrested 45-year-old Jonathan Llana about 3:15 p.m. in an area of southern Idaho outside of Pocatello about 10 miles from where the suspect crashed his car &hellip;" />
<meta property="og:url" content="http://www.watermarkonline.com/2019/05/27/suspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt/" />
<meta property="og:site_name" content="Watermark Online" />
<meta property="article:tag" content="Dennis Gwyther" />
<meta property="article:tag" content="Idaho" />
<meta property="article:tag" content="Idaho State Police" />
<meta property="article:tag" content="Jonathan Llana" />
<meta property="article:tag" content="LGBTQ rights" />
<meta property="article:tag" content="Matt Gwyther" />
<meta property="article:tag" content="SkyWest Airlines" />
<meta property="article:tag" content="Utah" />
<meta property="article:tag" content="Utah Highway Patrol" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2019-05-27T13:50:11+00:00" />
<meta property="og:image" content="http://www.watermarkonline.com/wp-content/uploads/2015/04/PoliceLawAbstr.jpg" />
<meta property="og:image:width" content="590" />
<meta property="og:image:height" content="288" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://www.watermarkonline.com/#website","url":"http://www.watermarkonline.com/","name":"Watermark Online","publisher":{"@id":"http://www.watermarkonline.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"http://www.watermarkonline.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"http://www.watermarkonline.com/2019/05/27/suspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt/#webpage","url":"http://www.watermarkonline.com/2019/05/27/suspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt/","inLanguage":"en-US","name":"Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt - Watermark Online","isPartOf":{"@id":"http://www.watermarkonline.com/#website"},"image":{"@type":"ImageObject","@id":"http://www.watermarkonline.com/2019/05/27/suspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt/#primaryimage","url":"http://www.watermarkonline.com/wp-content/uploads/2015/04/PoliceLawAbstr.jpg","caption":""},"primaryImageOfPage":{"@id":"http://www.watermarkonline.com/2019/05/27/suspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt/#primaryimage"},"datePublished":"2019-05-27T13:50:11+00:00","dateModified":"2019-05-27T13:50:11+00:00"},{"@type":"Article","@id":"http://www.watermarkonline.com/2019/05/27/suspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt/#article","isPartOf":{"@id":"http://www.watermarkonline.com/2019/05/27/suspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt/#webpage"},"author":{"@id":"http://www.watermarkonline.com/author/jeremywilliams/#author","name":"Jeremy Williams"},"publisher":{"@id":"http://www.watermarkonline.com/#organization"},"headline":"Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt","datePublished":"2019-05-27T13:50:11+00:00","dateModified":"2019-05-27T13:50:11+00:00","commentCount":0,"mainEntityOfPage":"http://www.watermarkonline.com/2019/05/27/suspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt/#webpage","image":{"@id":"http://www.watermarkonline.com/2019/05/27/suspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt/#primaryimage"},"keywords":"Dennis Gwyther,Idaho,Idaho State Police,Jonathan Llana,LGBTQ rights,Matt Gwyther,SkyWest Airlines,Utah,Utah Highway Patrol","articleSection":"Nation,News"},{"@type":"Person","@id":"http://www.watermarkonline.com/author/jeremywilliams/#author","name":"Jeremy Williams","image":{"@type":"ImageObject","@id":"http://www.watermarkonline.com/#personlogo","url":"http://0.gravatar.com/avatar/61468e6ceae84ca51c51528de0aef51a?s=96&d=mm&r=g","caption":"Jeremy Williams"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Watermark Online &raquo; Feed" href="http://www.watermarkonline.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Watermark Online &raquo; Comments Feed" href="http://www.watermarkonline.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Watermark Online &raquo; iCal Feed" href="http://www.watermarkonline.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Watermark Online &raquo; Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt Comments Feed" href="http://www.watermarkonline.com/2019/05/27/suspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.watermarkonline.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.0.3"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<!--[if lte IE 7]>
<style type="text/css">
html .jquerycssmenu{height: 1%;} /*Holly Hack for IE7 and below*/
</style>
<![endif]--> <link rel='stylesheet' id='yarppWidgetCss-css'  href='http://www.watermarkonline.com/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='bwp-rc-css'  href='http://www.watermarkonline.com/wp-content/plugins/bwp-recent-comments/css/bwp-recent-comments.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='http://www.watermarkonline.com/wp-includes/css/dist/block-library/style.min.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.watermarkonline.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='sidebar-login-css'  href='http://www.watermarkonline.com/wp-content/plugins/sidebar-login/assets/css/sidebar-login.css?ver=2.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpbdp_font_awesome-css'  href='https://use.fontawesome.com/releases/v5.6.3/css/all.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpbdp-widgets-css'  href='http://www.watermarkonline.com/wp-content/plugins/business-directory-plugin/assets/css/widgets.min.css?ver=5.5.4' type='text/css' media='all' />
<link rel='stylesheet' id='synved-shortcode-jquery-ui-css'  href='http://www.watermarkonline.com/wp-content/plugins/synved-shortcodes/synved-shortcode/jqueryUI/css/snvdshc/jquery-ui-1.9.2.custom.min.css?ver=1.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='synved-shortcode-layout-css'  href='http://www.watermarkonline.com/wp-content/plugins/synved-shortcodes/synved-shortcode/style/layout.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='synved-shortcode-jquery-ui-custom-css'  href='http://www.watermarkonline.com/wp-content/plugins/synved-shortcodes/synved-shortcode/style/jquery-ui.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='default-styles-css'  href='http://www.watermarkonline.com/wp-content/plugins/business-directory-plugin/themes/default/assets/styles.css?ver=4.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.watermarkonline.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='ThemeAlley_dropdowncss-css'  href='http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/css/dropdown.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='ThemeAlley_rtldropdown-css'  href='http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/css/dropdown.vertical.rtl.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='ThemeAlley_advanced_dropdown-css'  href='http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/css/default.advanced.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='ThemeAlley_wilto-css'  href='http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/css/wilto.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='ThemeAlley_litestyle-css'  href='http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/lite.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='ThemeAlley_prostyle-css'  href='http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/pro.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='ThemeAlley_Responsive-css'  href='http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/responsive.css?ver=5.0.3' type='text/css' media='all' />
<script type='text/javascript' src='http://www.watermarkonline.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/plugins/jquery-image-lazy-loading/js/jquery.lazyload.min.js?ver=1.7.1'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/plugins/sidebar-login/assets/js/jquery.blockUI.min.js?ver=2.70'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sidebar_login_params = {"ajax_url":"http:\/\/www.watermarkonline.com\/wp-admin\/admin-ajax.php","force_ssl_admin":"0","is_ssl":"0","i18n_username_required":"Please enter your username","i18n_password_required":"Please enter your password","error_class":"sidebar_login_error"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/plugins/sidebar-login/assets/js/sidebar-login.min.js?ver=2.7.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpgmza_google_api_status = {"message":"Enqueued","code":"ENQUEUED"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/plugins/wp-google-maps/wpgmza_data.js?ver=5.0.3'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/themes/ThemeAlley/js/respond.min.js?ver=5.0.3'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/themes/ThemeAlley/js/swfobject.js?ver=5.0.3'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/themes/ThemeAlley/js/tabcontent.js?ver=5.0.3'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/themes/ThemeAlley/js/tinynav.min.js?ver=5.0.3'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/themes/ThemeAlley/js/jquery.fittext.js?ver=5.0.3'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/themes/ThemeAlley/js/wilto.js?ver=5.0.3'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/themes/ThemeAlley/js/wilto.int.js?ver=5.0.3'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/themes/ThemeAlley/js/general.js?ver=5.0.3'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga&#038;property=5a331c277820fd001360af1d'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/plugins/synved-shortcodes/synved-shortcode/script/jquery.ba-bbq.min.js?ver=1.2.1'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/plugins/synved-shortcodes/synved-shortcode/script/jquery.scrolltab.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-includes/js/jquery/ui/accordion.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/plugins/synved-shortcodes/synved-shortcode/script/jquery-unselectable.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/plugins/synved-shortcodes/synved-shortcode/script/base.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/plugins/synved-shortcodes/synved-shortcode/script/custom.js?ver=1.0'></script>
<link rel='https://api.w.org/' href='http://www.watermarkonline.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.watermarkonline.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.watermarkonline.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.0.3" />
<link rel='shortlink' href='http://www.watermarkonline.com/?p=277933' />
<link rel="alternate" type="application/json+oembed" href="http://www.watermarkonline.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.watermarkonline.com%2F2019%2F05%2F27%2Fsuspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.watermarkonline.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.watermarkonline.com%2F2019%2F05%2F27%2Fsuspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt%2F&#038;format=xml" />
<meta name="generator" content="Custom Login v3.2.8" />
<style type='text/css'>
img.lazy { display: none; }
</style>
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="http://www.watermarkonline.com"><link rel="https://theeventscalendar.com/" href="http://www.watermarkonline.com/wp-json/tribe/events/v1/" />
<style type="text/css"></style>
</head>

<body class="post-template-default single single-post postid-277933 single-format-standard tribe-no-js tribe-theme-parent-ThemeAlley tribe-theme-child-Wmrk-Azurite.Pro gecko wpbdp-with-button-styles">

	<!-- Wrapper one starts here -->
	<div id="wrapper_one">	
	<!-- Wrapper four starts here -->
	<div id="wrapper_four">    

		<!-- Wrapper two starts here -->
		<div id="wrapper_two">

        	<!-- Header socialn search starts here -->
            <div id="header_social_cont">
            

            	<div id="header_social">

<!-----///////////////////////////////////////////////////////////-------- Upper Navigation Menu -----///////////////////////////////////////////////////////////-------->
<div class="menu-resources-container"><ul id="menu-resources" class="sf-menu"><li id="menu-item-30011" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30011"><a href="http://www.watermarkonline.com/aboutcontact/">About/Contact</a></li>
<li id="menu-item-29988" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29988"><a href="http://www.watermarkonline.com/category/digital-publication/">Digital Publications</a></li>
<li id="menu-item-29990" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29990"><a href="http://www.watermarkonline.com/distribution-map/">Distribution Map</a></li>
<li id="menu-item-29981" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29981"><a href="http://www.watermarkonline.com/advertise/">Advertise</a></li>
<li id="menu-item-84796" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84796"><a href="http://www.watermarkonline.com/adverts/">Classified Adverts</a></li>
<li id="menu-item-29983" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29983"><a href="http://www.watermarkonline.com/business-directory/">Business Directory</a></li>
</ul></div><!--<p style="color:#6f6f6f; float:left; display:block; margin:auto 0; padding:10px 0 0 0; ">This is where I would like a menu to go.</p>-->
<!-----//////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////-------->
                
                	<div class="header_rss">
                    
                    	<p><a href="http://www.watermarkonline.com/feed/"><img src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/rss.png" width="35" height="35" border="0" alt="Rss" /></a></p>
                    
                    </div>
                    
<form method="get" id="searchform" action="http://www.watermarkonline.com/">
<div><input type="text" size="18" value="" name="s" id="s" />
<input type="submit" id="searchsubmit" value="Search" class="btn" />
</div>
</form>
                    
                	<div class="header_social_icons">
                    
                                    <ul>
    
                                            
                                            
                                            
                                            
                                            
                                            
                                        
                                                                        
                                    </ul>                    
                    
                    
                    
                    </div>                                       
                
            
            	</div>
            
            </div>
            <!-- Header socialn search starts here -->


			<!-- Wrapper three starts here -->
			<div id="wrapper_three">
            

				                 <!-- Logo Section starts here -->
                 <div id="logo_section">
                    
                                                        <div id="logo">
                                <p class="logo_title"><a href="http://www.watermarkonline.com/"><img src="http://www.watermarkonline.com/wp-content/uploads/site-logo-06-450px.png" alt="Watermark Online"/></a></p>
                            </div>                        
                                                        
                            
  <!--------- Widgetized Leaderboard Ad Space --------->      
                   
  <div class="wmrk-leaderboard-ad"><div class="AdSpeedWP">
		<!-- AdSpeed.com WP Ad Tag 8.0.2 for [Zone] #43887 [Any Dimension] -->
		<script type="text/javascript" src="//g.adspeed.net/ad.php?do=js&zid=43887&wd=-1&ht=-1&target=_blank&cb=1559052660"></script>
		<!-- AdSpeed.com End --></div></div>
  <!--------------------------------------------------->
                            
                           
            
                </div>	
                <!-- Logo Section ends here -->	
				                			

                  
                <!-- Content Section starts here -->
                <div id="content_section">

<!-----///////////////////////////////////////////////////////////-------- Promo Widget Location -----///////////////////////////////////////////////////////////-------->

<div id="showcaseWidgets">

<div class="wmrk-showcase show01"><a href="http://www.watermarkonline.com/2019/05/01/the-lgbt-center-to-honor-community-leaders-at-harvey-milk-diversity-breakfast/" target="_self" class="widget_sp_image-image-link" title=""><img width="590" height="288" alt="" class="attachment-full aligncenter" style="max-width: 590px;max-height: 288px;" src="http://www.watermarkonline.com/wp-content/uploads/2016/05/HarveyMilkAbstr.jpg" /><div class="widget_sp_image-description" ><p>The Center to honor LGBTQ leaders at Harvey Milk Breakfast</p>
</div></div>
<div class="wmrk-showcase show02"><a href="http://www.watermarkonline.com/2019/05/01/jane-castor-sworn-in-as-tampas-59th-first-openly-lgbtq-mayor/" target="_self" class="widget_sp_image-image-link" title=""><img width="452" height="288" alt="" class="attachment-full aligncenter" style="max-width: 452px;max-height: 288px;" src="http://www.watermarkonline.com/wp-content/uploads/2019/05/Jane-Castor.jpg" /><div class="widget_sp_image-description" ><p>Jane Castor sworn in as Tampa’s first openly LGBTQ mayor</p>
</div></div>
<div class="wmrk-showcase show03"><a href="http://www.watermarkonline.com/2019/05/09/lgbtq-christians-preach-their-gospel/" target="_self" class="widget_sp_image-image-link" title=""><img width="1024" height="500" alt="" class="attachment-full aligncenter" style="max-width: 1024px;max-height: 500px;" src="http://www.watermarkonline.com/wp-content/uploads/2019/05/2609-Wanzie-Abstact.jpg" /><div class="widget_sp_image-description" ><p>LGBTQ Christians preach their gospel</p>
</div></div>
<div class="wmrk-showcase show04"><a href="http://www.watermarkonline.com/2019/05/09/the-28th-annual-orlando-international-fringe-theatre-festival-showcases-30-lgbtq-shows/" target="_self" class="widget_sp_image-image-link" title=""><img width="520" height="254" alt="" class="attachment-large aligncenter" style="max-width: 520px;max-height: 254px;" src="http://www.watermarkonline.com/wp-content/uploads/2019/05/2609-Orlando-Fringe-Abstact.jpg" /><div class="widget_sp_image-description" ><p>Orlando Fringe Festival showcases 30+ LGBTQ shows</p>
</div></div>
<div class="wmrk-showcase show05"><a href="http://www.watermarkonline.com/2019/04/04/take-the-2019-lgbtq-community-survey-and-have-your-voice-heard/" target="_self" class="widget_sp_image-image-link" title=""><img width="590" height="288" alt="" class="attachment-full aligncenter" style="max-width: 590px;max-height: 288px;" src="http://www.watermarkonline.com/wp-content/uploads/2019/04/2019-survey.jpg" /><div class="widget_sp_image-description" ><p>Take the 2019 LGBTQ community survey</p>
</div></div></a>

<!--Special Area--->

</div>

<!-----///////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////-------->                    
   
                    
<!--////////////////-- Menu Section starts here (Old Menu Commented Out... Maybe I should put it back later)--///////////////////////-->
                    
            		<!--	<div id="menu">
			<ul id="Main_nav" class="dropdown dropdown-horizontal"><li id="menu-item-29987" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29987"><a href="http://www.watermarkonline.com/category/news/">All News</a></li>
<li id="menu-item-29976" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29976"><a href="http://www.watermarkonline.com/category/news/orlando-1/">Orlando</a></li>
<li id="menu-item-29975" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29975"><a href="http://www.watermarkonline.com/category/news/tampa-bay-lgbt-news/">Tampa Bay</a></li>
<li id="menu-item-29977" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29977"><a href="http://www.watermarkonline.com/category/news/florida-lgbt-news/">State</a></li>
<li id="menu-item-29974" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29974"><a href="http://www.watermarkonline.com/category/news/nation/">Nation</a></li>
<li id="menu-item-29979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29979"><a href="http://www.watermarkonline.com/category/news/world/">World</a></li>
<li id="menu-item-30006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30006"><a href="http://www.watermarkonline.com/category/features-1/">Features</a></li>
<li id="menu-item-30007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30007"><a href="http://www.watermarkonline.com/category/opinion/">Opinion</a></li>
<li id="menu-item-56133" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56133"><a href="http://www.watermarkonline.com/category/photos/">Photos</a></li>
<li id="menu-item-86925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-86925"><a href="/events/">Events</a></li>
</ul>			
                        </div>
                     <script type="text/javascript">  
                                    jQuery(document).ready(function(){
										
										jQuery.noConflict();
										
										jQuery('#Main_nav').tinyNav({
                                        header: true
                                      });
									});
                                </script>  

                    -->
                    <!-- Menu Section ends here -->		                                      
								
                    <!-- Inner Content Section starts here -->
                    <div id="inner_content_section">
               			                        
                        	             


 <!-- Menu Section starts here -->
                    
            			<div id="menu">
							<ul id="Main_nav" class="dropdown dropdown-horizontal"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29987"><a href="http://www.watermarkonline.com/category/news/">All News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29976"><a href="http://www.watermarkonline.com/category/news/orlando-1/">Orlando</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29975"><a href="http://www.watermarkonline.com/category/news/tampa-bay-lgbt-news/">Tampa Bay</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29977"><a href="http://www.watermarkonline.com/category/news/florida-lgbt-news/">State</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29974"><a href="http://www.watermarkonline.com/category/news/nation/">Nation</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29979"><a href="http://www.watermarkonline.com/category/news/world/">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30006"><a href="http://www.watermarkonline.com/category/features-1/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30007"><a href="http://www.watermarkonline.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56133"><a href="http://www.watermarkonline.com/category/photos/">Photos</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-86925"><a href="/events/">Events</a></li>
</ul>			
                        </div>
                        

  
  								<script type="text/javascript">  
                                    jQuery(document).ready(function(){
										
										jQuery.noConflict();
										
										jQuery('#Main_nav').tinyNav({
                                        header: true
                                      });
									});
                                </script>  

                    
                    <!-- Menu Section ends here -->



                        <!-- Main Content Section starts here -->
                        <div id="main_content_section">
                

																																	<!-- Actual Post starts here -->
												<div class="actual_post post-277933 post type-post status-publish format-standard has-post-thumbnail hentry category-nation category-news tag-dennis-gwyther tag-idaho tag-idaho-state-police tag-jonathan-llana tag-lgbtq-rights tag-matt-gwyther tag-skywest-airlines tag-utah tag-utah-highway-patrol" id="post-277933">
													<div class="ta_meta_container">
                                                        <div class="actual_post_title">


<!------------------- Posting Category-------------------> 													
<div class="postCategory"><ul class="post-categories">
	<li><a href="http://www.watermarkonline.com/category/news/nation/" rel="category tag">Nation</a></li>
	<li><a href="http://www.watermarkonline.com/category/news/" rel="category tag">News</a></li></ul></div>
                                                            <h2>Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt</h2>
                                                        
<!----------------------------------------------------- Posting Author-------------------------------------------------------->                        
<div class="wmrk-actual_post_posted">
<!--<a href="http://www.watermarkonline.com/author/jeremywilliams/" title="Posts by Wire Report" rel="author">Wire Report</a> -->
By : <span>Wire Report</span></div> 


<!------------------------------------------------------ Posting Date -------------------------------------------------------->
<div class="wmrk-actual_post_date"> <span>May 27, 2019</span></div>

<!----------------------------------------------------- Posting Comments ----------------------------------------------------->
<div class="wmrk-actual_post_comments">Comments:&nbsp;<span class="dsq-postid" data-dsqidentifier="277933 http://www.watermarkonline.com/?p=277933">0</span></div>
													
<!--closes div that surrounds post headline--></div>
                                                        
<!-----///////////////////////////////////////////////////////////-------- Featured Image -----///////////////////////////////////////////////////////////--------> 
<div id="featuredImage"> 
<a href="http://www.watermarkonline.com/2019/05/27/suspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt/" title="Permalink to Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt" rel="bookmark">
<img width="590" height="288" src="http://www.watermarkonline.com/wp-content/uploads/2015/04/PoliceLawAbstr.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="http://www.watermarkonline.com/wp-content/uploads/2015/04/PoliceLawAbstr.jpg 590w, http://www.watermarkonline.com/wp-content/uploads/2015/04/PoliceLawAbstr-350x171.jpg 350w, http://www.watermarkonline.com/wp-content/uploads/2015/04/PoliceLawAbstr-150x73.jpg 150w, http://www.watermarkonline.com/wp-content/uploads/2015/04/PoliceLawAbstr-500x244.jpg 500w" sizes="(max-width: 590px) 100vw, 590px" data-attachment-id="72046" data-permalink="http://www.watermarkonline.com/2015/04/24/gay-students-attacked-by-peers-at-atlanta-school/policelawabstr/" data-orig-file="http://www.watermarkonline.com/wp-content/uploads/2015/04/PoliceLawAbstr.jpg" data-orig-size="590,288" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="PoliceLawAbstr" data-image-description="" data-medium-file="http://www.watermarkonline.com/wp-content/uploads/2015/04/PoliceLawAbstr-350x171.jpg" data-large-file="http://www.watermarkonline.com/wp-content/uploads/2015/04/PoliceLawAbstr.jpg" /> </a>


<!---------------------------------------------Social Sharing Addition--------------------------------------------------------->
<div class="socialSharing">
<h3>Share this story:</h3>
                                                        	<p><a target="_blank" href="http://www.stumbleupon.com/submit?url=http%3A%2F%2Fwww.watermarkonline.com%2F2019%2F05%2F27%2Fsuspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt%2F&amp;Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt"><img src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/stumbleupon.png" /></a></p>
                                                            <p><a target="_blank" href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.watermarkonline.com%2F2019%2F05%2F27%2Fsuspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt%2F&amp;text=Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt"><img src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/twitter.png" /></a></p>
                                                            <p><a target="_blank" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.watermarkonline.com%2F2019%2F05%2F27%2Fsuspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt%2F&amp;t=Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt"><img src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/facebook.png" /></a></p>
                                                            <p><a target="_blank" href="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.watermarkonline.com%2F2019%2F05%2F27%2Fsuspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt%2F&description=Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt"><img src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/pinterest.png" /></a></p>
                                                            <p><a target="_blank" href="http://del.icio.us/post?url=http%3A%2F%2Fwww.watermarkonline.com%2F2019%2F05%2F27%2Fsuspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt%2F&amp;title=Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt"><img src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/delicious.png" /></a></p>
                                                            <p><a target="_blank" href="http://www.linkedin.com/shareArticle?mini=true&url=http%3A%2F%2Fwww.watermarkonline.com%2F2019%2F05%2F27%2Fsuspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt%2F&title=Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt"><img src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/linkedin.png" /></a></p>
                                                            <p><a target="_blank" href="http://reddit.com/login?dest=%2Fsubmit%3Furl%3Dhttp%3A%2F%2Fwww.watermarkonline.com%2F2019%2F05%2F27%2Fsuspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt%2F"><img src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/reddit.png" /></a></p>
                                                        </div>	


<!-----///////////////////////////////////////////////////////////-------- Tags Div ----///////////////////////////////////////////////////////////---------> 
<div class="postTags">
<!-- <div class="wmrk-ActualPostAuthor"> -->
                                                                        
<div class="wmrk-metadata">
<!--<span class="label">Category:</span>
<span class="text"><a href="http://www.watermarkonline.com/category/news/nation/" rel="category tag">Nation</a>, <a href="http://www.watermarkonline.com/category/news/" rel="category tag">News</a></span>-->
<p><span class="label">Tags:</span><span class="text"><a href="http://www.watermarkonline.com/tag/dennis-gwyther/" rel="tag">Dennis Gwyther</a>, <a href="http://www.watermarkonline.com/tag/idaho/" rel="tag">Idaho</a>, <a href="http://www.watermarkonline.com/tag/idaho-state-police/" rel="tag">Idaho State Police</a>, <a href="http://www.watermarkonline.com/tag/jonathan-llana/" rel="tag">Jonathan Llana</a>, <a href="http://www.watermarkonline.com/tag/lgbtq-rights/" rel="tag">LGBTQ rights</a>, <a href="http://www.watermarkonline.com/tag/matt-gwyther/" rel="tag">Matt Gwyther</a>, <a href="http://www.watermarkonline.com/tag/skywest-airlines/" rel="tag">SkyWest Airlines</a>, <a href="http://www.watermarkonline.com/tag/utah/" rel="tag">Utah</a>, <a href="http://www.watermarkonline.com/tag/utah-highway-patrol/" rel="tag">Utah Highway Patrol</a></span></p>														</div> 


<!--closing featured image div--> </div>

<!-----///////////////////////////////////////////////////////////-------- Ratings ???  -----///////////////////////////////////////////////////////////-------->
                              

 
<!-----///////////////////////////////////////////////////////////-------- /metadata -----///////////////////////////////////////////////////////////---------->
</div>

                                                                                                                
                                                    </div>	
                                                    
                                                    <!-- Post entry starts here -->												
													<div class="post_entry">
																												<div class="entry">
															<p class="lead">BOISE, Idaho (AP) | Idaho police captured a man May 24 suspected of shooting and killing a motorist in northern Utah earlier this week after a two-day manhunt.</p>
<p>Officers arrested 45-year-old Jonathan Llana about 3:15 p.m. in an area of southern Idaho outside of Pocatello about 10 miles from where the suspect crashed his car into a canal after a police pursuit May 22, according to news releases from Idaho State Police and the Utah Highway Patrol. LLana had broken into a house in the area and stolen an all-terrain vehicle, they said. No officers or residents were injured.<span id="more-277933"></span></p>
<p>The Los Angeles man is charged with murder and attempted murder in connection with the May 22 shooting that killed Dennis Gwyther, 50, of Salt Lake City and injured Gwyther&#8217;s passenger.</p>
<p>The victim&#8217;s husband, Matt Gwyther, said in a statement he wants &#8220;swift justice&#8221; for the suspect and celebrated Llana&#8217;s arrest on his Facebook account.</p>
<p>Matt Gwyther said in a Facebook post that he and Dennis Gwyther married on Dec. 10, 2013, the day same-sex marriage was legalized in Utah. He said Dennis Gwyther was the &#8220;love of his life&#8221; who enjoyed being the &#8220;bonus dad&#8221; to his two teenage children and enjoyed having fun and laughing.</p>
<p>He said Dennis Gwyther loved kidding around and playing jokes and was like a &#8220;kid inside an adult body.&#8221; He said he loved gadgets and was a genius with technology, loved writing and did sound and lighting for clubs in Salt Lake City.</p>
<p>Dennis Gwyther was also a strong advocate for LGBTQ rights, his husband said.</p>
<p>Utah officials said the two victims were heading toward Idaho on Interstate 84 in northern Utah when the suspect fired multiple rounds at their vehicle. Idaho troopers chased Llana&#8217;s vehicle until it crashed into a canal in southern Idaho. Llana then fled on foot, police said.</p>
<p>The motive of the shooting is still unknown, Utah Highway Patrol Sgt. Nick Street said.</p>
<p>Utah Bureau of Investigation Sgt. J.T. Jensen told reporters May 24 that it&#8217;s unknown if the shooting was random, but that authorities believe it was unprovoked.</p>
<p>Gwyther worked as a flight attendant for SkyWest Airlines, company spokesman Wes Horrocks said. The company is shocked and saddened by the killing, Horrocks said.</p>
															<div class="clear"></div>
																																			
														</div>
														
																												
													</div>
  
                                                
<!---------------------------------------------Social Sharing Addition--------------------------------------------------------->
<div class="socialSharing-bottomPost">
<h3>Share this story:</h3>
                                                        	<p><a target="_blank" href="http://www.stumbleupon.com/submit?url=http%3A%2F%2Fwww.watermarkonline.com%2F2019%2F05%2F27%2Fsuspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt%2F&amp;Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt"><img src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/stumbleupon.png" /></a></p>
                                                            <p><a target="_blank" href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.watermarkonline.com%2F2019%2F05%2F27%2Fsuspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt%2F&amp;text=Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt"><img src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/twitter.png" /></a></p>
                                                            <p><a target="_blank" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.watermarkonline.com%2F2019%2F05%2F27%2Fsuspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt%2F&amp;t=Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt"><img src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/facebook.png" /></a></p>
                                                            <p><a target="_blank" href="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.watermarkonline.com%2F2019%2F05%2F27%2Fsuspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt%2F&description=Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt"><img src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/pinterest.png" /></a></p>
                                                            <p><a target="_blank" href="http://del.icio.us/post?url=http%3A%2F%2Fwww.watermarkonline.com%2F2019%2F05%2F27%2Fsuspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt%2F&amp;title=Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt"><img src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/delicious.png" /></a></p>
                                                            <p><a target="_blank" href="http://www.linkedin.com/shareArticle?mini=true&url=http%3A%2F%2Fwww.watermarkonline.com%2F2019%2F05%2F27%2Fsuspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt%2F&title=Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt"><img src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/linkedin.png" /></a></p>
                                                            <p><a target="_blank" href="http://reddit.com/login?dest=%2Fsubmit%3Furl%3Dhttp%3A%2F%2Fwww.watermarkonline.com%2F2019%2F05%2F27%2Fsuspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt%2F"><img src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/reddit.png" /></a></p>
                                                        </div>	


  <!-- post entry ends here -->
                                                   
	                                                													<!-- Bio starts here -->
                                                    <div class="post_author_bio">
                                                        <div class="post_author_bio_bio">
                                                        
                                                        	<div class="post_author_bio_bio_pic">
                                                            	<img src="http://0.gravatar.com/avatar/61468e6ceae84ca51c51528de0aef51a?s=88&#038;d=mm&#038;r=g" width="88" height="88" alt="Avatar" class="avatar avatar-88 wp-user-avatar wp-user-avatar-88 photo avatar-default" />                                                            </div>
                                                            
                                                        	<div class="post_author_bio_bio_desc">
                                                            	<p class="post_author_pic">Wire Report</p>
                                                                <p></p>
                                                            </div>                                                            
                                                        
                                                        
                                                        </div>
                                                        <div class="post_author_bio_social">
                                                        
                                                        	
                                                            	
                                                                                                                                                                                                 <!-- NOTE THIS CODE IS COMMENTED OUT BECAUSE THE WEBSITE LINK IS UGLY AND POINTLESS. IF IT'S DESIRED TO SHOW AGAIN
								     THAN SIMPLY REMOVE THE COMMENTS AROUND "authors_website" -->
                                                                <!-- <div class="authors_website">
                                                                
                                                                	<p><a href="http://www.watermarkonline.com">Visit Author's Website</a></p>
                                                            	</div> -->
                                                                                                                            
                                                        	
                                                            	 
                                                                                                                                
                                                                
                                                        	
                                                            	   
                                                                
                                                                                                                                                                                      
                                                        
                                                        </div>                                                        
                                                    </div>
                                                    <!-- Bio ends here -->       
                                                                                                        
                                                   <!--/////////////////////////////////////////////---Related Posts---////////////////////////////////////-->
										<div class="adsBetweenPosts">
										<!--<a href="http://www.watermarkonline.com/component/banners/click/86">
										<img src="http://www.watermarkonline.com/images/banners/W20_01_WinterHavenFiat_Jan15.gif"></a>-->
										
										<!-- AdSpeed.com Serving Code 7.9.5 for [Zone] Box Ads Within Posts [Any Dimension] -->
										<script type="text/javascript" src="http://g.adspeed.net/ad.php?do=js&amp;zid=43522&amp;wd=-1&amp;ht=-1&amp;target=_top"></script>
										<!-- AdSpeed.com End -->


										</div>                                                 
                                                    <!--/////////////////////////////////////////////////////////////////////////////////////////////////-->
                                                    
                                                                                                        <!-- Next/prev post starts here -->  
                                                    <div class="single_np">
                                                    
                                                    	<div class="single_np_prev">
                                                        	<p class="single_np_prev_np">Previous Post</p>
                                                            <p><a href="http://www.watermarkonline.com/2019/05/24/mormon-county-commissioner-in-utah-comes-out-as-gay/" rel="prev">Mormon county commissioner in Utah comes out as gay</a></p>
                                                        </div>
                                                        
                                                    	<div class="single_np_next">
                                                        	<p class="single_np_next_np">Next Post</p>
                                                            <p><a href="http://www.watermarkonline.com/2019/05/28/alabama-lawmakers-pass-workaround-bill-on-same-sex-marriage/" rel="next">Alabama lawmakers pass workaround bill on same-sex marriage</a></p>
                                                        </div>                                                        
                                                    
                                                    </div>                                                    
                                                    <!-- Next/prev post ends here --> 
                                                                                                        
<!--/////////////////////////////////////////////---Related Posts---////////////////////////////////////-->
                                                                                                        <!-- Related Posts starts here -->  
                                                    <div class="single_related">
                                                    
                                                    	<div class="single_related_title">
															
                                                        </div>
                                                        
                                                    	<div class="wmrk-single_related_posts">
															<div class="related_posts_single">
																<div class='yarpp-related'>
<h3>Posts Related to this Article</h3>
<div class="yarpp-thumbnails-horizontal">
<a class='yarpp-thumbnail' href='http://www.watermarkonline.com/2017/05/26/law-criminalizing-online-harassment-may-unconstitutional/' title='Law criminalizing online harassment may be unconstitutional'>
<div class='relatedposts-trim'><img width="120" height="120" src="http://www.watermarkonline.com/wp-content/uploads/2017/05/OnlineSlursAbstr-120x120.jpg" class="attachment-yarpp-thumbnail size-yarpp-thumbnail wp-post-image" alt="" srcset="http://www.watermarkonline.com/wp-content/uploads/2017/05/OnlineSlursAbstr-120x120.jpg 120w, http://www.watermarkonline.com/wp-content/uploads/2017/05/OnlineSlursAbstr-185x185.jpg 185w, http://www.watermarkonline.com/wp-content/uploads/2017/05/OnlineSlursAbstr-45x45.jpg 45w" sizes="(max-width: 120px) 100vw, 120px" data-attachment-id="104575" data-permalink="http://www.watermarkonline.com/2017/05/26/law-criminalizing-online-harassment-may-unconstitutional/onlineslursabstr-2/" data-orig-file="http://www.watermarkonline.com/wp-content/uploads/2017/05/OnlineSlursAbstr.jpg" data-orig-size="590,288" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="OnlineSlursAbstr" data-image-description="" data-medium-file="http://www.watermarkonline.com/wp-content/uploads/2017/05/OnlineSlursAbstr-350x171.jpg" data-large-file="http://www.watermarkonline.com/wp-content/uploads/2017/05/OnlineSlursAbstr.jpg" /></div><span class="yarpp-thumbnail-title">Law criminalizing online harassment may be unconstitutional</span></a>
<a class='yarpp-thumbnail' href='http://www.watermarkonline.com/2015/03/17/25-gay-rights-activists-arrested-in-idaho-capitol-protest/' title='25 gay rights activists arrested in Idaho Capitol protest'>
<div class='relatedposts-trim'><img width="120" height="120" src="http://www.watermarkonline.com/wp-content/uploads/2015/01/GayIdahoAbstr-120x120.jpg" class="attachment-yarpp-thumbnail size-yarpp-thumbnail wp-post-image" alt="idaho gay lgbt" srcset="http://www.watermarkonline.com/wp-content/uploads/2015/01/GayIdahoAbstr-120x120.jpg 120w, http://www.watermarkonline.com/wp-content/uploads/2015/01/GayIdahoAbstr-185x185.jpg 185w, http://www.watermarkonline.com/wp-content/uploads/2015/01/GayIdahoAbstr-32x32.jpg 32w, http://www.watermarkonline.com/wp-content/uploads/2015/01/GayIdahoAbstr-64x64.jpg 64w, http://www.watermarkonline.com/wp-content/uploads/2015/01/GayIdahoAbstr-96x96.jpg 96w, http://www.watermarkonline.com/wp-content/uploads/2015/01/GayIdahoAbstr-128x128.jpg 128w, http://www.watermarkonline.com/wp-content/uploads/2015/01/GayIdahoAbstr-45x45.jpg 45w" sizes="(max-width: 120px) 100vw, 120px" data-attachment-id="67830" data-permalink="http://www.watermarkonline.com/2015/01/16/idaho-moves-forward-gender-identity-sexual-orientation-protections/gayidahoabstr/" data-orig-file="http://www.watermarkonline.com/wp-content/uploads/2015/01/GayIdahoAbstr.jpg" data-orig-size="590,288" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="GayIdahoAbstr" data-image-description="" data-medium-file="http://www.watermarkonline.com/wp-content/uploads/2015/01/GayIdahoAbstr-350x171.jpg" data-large-file="http://www.watermarkonline.com/wp-content/uploads/2015/01/GayIdahoAbstr.jpg" /></div><span class="yarpp-thumbnail-title">25 gay rights activists arrested in Idaho Capitol protest</span></a>
<a class='yarpp-thumbnail' href='http://www.watermarkonline.com/2014/01/02/utah-takes-marriage-equality-fight-to-supreme-court/' title='Utah takes marriage equality fight to Supreme Court'>
<div class='relatedposts-trim'><span class="yarpp-thumbnail-default"><img src="http://www.watermarkonline.com/wp-content/plugins/yet-another-related-posts-plugin/default.png"/></span></div><span class="yarpp-thumbnail-title">Utah takes marriage equality fight to Supreme Court</span></a>
</div>
</div>
															</div>
                                                        </div>                                                        
                                                    
                                                    </div>                                                    
                                                    <!-- Related Posts ends here -->
                                                  
													<!--//////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////--->
                                                    
												</div>
												<!-- Actual Post ends here -->		
												
<div id="disqus_thread"></div>
																								                
                
                        </div>	
                        <!-- Main Content Section ends here -->

                        <!-- Sidebar Section starts here -->
                                                <div id="sidebar_section">
							

                            
                            <!-- Ads start here -->
							                            <!-- Ads end here -->
                            
                            <!-- FeedBurner starts here -->


                           <div id="feed_social">
                         
<div class="widget_text wmrk-solicitation"><div class="textwidget custom-html-widget"><p>Sign Up for our eNewsletter</p>

<div role="form" class="wpcf7" id="wpcf7-f158643-o1" lang="en-US" dir="ltr">
<div class="screen-reader-response"></div>
<form action="/2019/05/27/suspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt/#wpcf7-f158643-o1" method="post" class="wpcf7-form" novalidate="novalidate">
<div style="display: none;">
<input type="hidden" name="_wpcf7" value="158643" />
<input type="hidden" name="_wpcf7_version" value="5.1.1" />
<input type="hidden" name="_wpcf7_locale" value="en_US" />
<input type="hidden" name="_wpcf7_unit_tag" value="wpcf7-f158643-o1" />
<input type="hidden" name="_wpcf7_container_post" value="0" />
<input type="hidden" name="g-recaptcha-response" value="" />
</div>
<p><label> Your Email (required)<br />
    <span class="wpcf7-form-control-wrap your-email"><input type="email" name="your-email" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-email wpcf7-validates-as-required wpcf7-validates-as-email" aria-required="true" aria-invalid="false" /></span> </label></p>

<p><input type="submit" value="Send" class="wpcf7-form-control wpcf7-submit" /></p>
<div class="wpcf7-response-output wpcf7-display-none"></div></form></div>]
<br><br>
<p>Follow Us</p>
<div class="follow-us">
<ul>
	<li><a href="http://www.facebook.com/WatermarkFL"><img alt="" src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/facebook.png" /></a></li>
	<li><a href="http://www.twitter.com/WatermarkOnline"><img alt="" src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/twitter.png" /></a></li>
	<li><a href="#"><img alt="" src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/vine.png" /></a></li>
	<li><a href="http://pinterest.com/watermarkonline/"><img alt="" src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/pinterest.png" /></a></li>
	<li><a href="http://instagram.com/watermarkonline"><img alt="" src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/instagram.png" /></a></li>
	<li><a href="http://www.youtube.com/watermarkonline"><img alt="" src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/socialicons/youtube.png" /></a></li>
</ul>
</div></div></div>
										                                            
                                                                                        
                                                                                       
                                            
                                                                        
                            </div>
							<!-- FeedBurner ends here -->
                            
                            <!-- Social box starts here -->
                            <div id="sidebar_search_social">
                            	<div id="social_section">
                                    <ul>
    
                                            
                                            
                                            
                                            
                                            
                                            
                                                                                
                                        <li><a href="http://www.watermarkonline.com/feed/"><img src="http://www.watermarkonline.com/wp-content/themes/Wmrk-Azurite.Pro/images/rss.png" width="35" height="35" border="0" alt="Rss" /></a></li>
                                                                        
                                    </ul>
								</div>		
                                
                            								
<div class="seach_section">

									<form method="get" action="http://www.watermarkonline.com/">
									<fieldset>
										<p class="searchtext"><input type="text" onblur="if(this.value=='') this.value='Enter search query here...'" onfocus="if(this.value=='Enter search query here...') this.value=''" value="Enter search query here..." name="s" class="text" /></p>
										<p class="searchsub"><input class="submit" type="submit" value="Go" /></p>
									</fieldset>
									</form>
							</div>                             
                            
                            
                            </div>
                            <!-- Social box ends here -->                            


                            <!--Popular box starts here-->
							 
                           <!--Popular box ends here-->   


                           <!-- Sidebar Starts Here --> 
                            <div id="sidebar">


                            			<!--video column starts here-->
																				<!--video column ends here-->     
                                        
                                                             
                            
										                          
                            
                            
                            
										<div id="adspeed-ad-server-2" class="sidebar_widget AdSpeed Ad Server">
																			
																			<div class="widget"><div class="AdSpeedWP">
		<!-- AdSpeed.com WP Ad Tag 8.0.2 for [Zone] #43867 [Any Dimension] -->
		<script type="text/javascript" src="//g.adspeed.net/ad.php?do=js&zid=43867&wd=-1&ht=-1&target=_blank&cb=1559052663"></script>
		<!-- AdSpeed.com End --></div></div>
																			
																		</div><div id="custom_html-13" class="widget_text sidebar_widget widget_custom_html">
																			
																			<div class="widget_text widget"><h3 class="widgettitle">Latest Issue</h3><div class="textwidget custom-html-widget"><div data-configid="3597836/69924627[" style="width: 100%; height: 284px;" class="issuuembed"></div><script type="text/javascript" src="//e.issuu.com/embed.js" async="true"></script></div></div>
																			
																		</div><div id="tribe-events-adv-list-widget-2" class="wmrk-events-recent sidebar_widget tribe-events-adv-list-widget">
																			
																			<div class="widget"><h3 class="widgettitle">Upcoming Events</h3>
		<!-- Event  -->
		<div class="type-tribe_events post-153048 tribe-clearfix tribe-events-venue-149976">
			
<div class="tribe-mini-calendar-event event--1 ">
	
	<div class="list-date">
					<span class="list-dayname">
				Tue			</span>
		
		<span class="list-daynumber">28</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="http://www.watermarkonline.com/event/lgbtq-loss-grief-support-group/2019-05-28/" rel="bookmark">LGBTQ Loss and Grief Support Group</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">May 28 @ 6:00 pm</span> - <span class="tribe-event-time">7:15 pm</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
							<div class="tribe-events-location tribe-section-s">
					<span class="tribe-events-venue"><a href="http://www.watermarkonline.com/venue/friendship-center/" title="Friendship Center">Friendship Center</a></span>
			
			
							<div>
											<span class="tribe-events-locality">Sarasota</span>
					
					
									</div>				</div>
			
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<!-- Event  -->
		<div class="type-tribe_events post-270302 tribe-clearfix tribe-events-venue-91404 tribe-events-organizer-107792">
			
<div class="tribe-mini-calendar-event event--1 ">
	
	<div class="list-date">
					<span class="list-dayname">
				Jun			</span>
		
		<span class="list-daynumber">01</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="http://www.watermarkonline.com/event/jared-violin-live-at-the-museum/" rel="bookmark">Jared Violin, Live at the Museum!</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">June 1 @ 6:30 pm</span> - <span class="tribe-event-time">9:00 pm</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
							<div class="tribe-events-location tribe-section-s">
					<span class="tribe-events-venue"><a href="http://www.watermarkonline.com/?post_type=tribe_venue&#038;p=91404" title="Modernism Museum Mount Dora">Modernism Museum Mount Dora</a></span>
			
			
							<div>
											<span class="tribe-events-locality">Mount Dora</span>
					
					
									</div>				</div>
			
							<div class="tribe-events-organizer tribe-section-s">
					<span class="tribe-events-organizer">
					Organizer:
					<a href="http://www.watermarkonline.com/organizer/modernism-museum-mount-dora/" title="Modernism Museum Mount Dora">Modernism Museum Mount Dora</a><div class="tribe-events-tel">352-385-0034</div>				</span>				</div>
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<!-- Event  -->
		<div class="type-tribe_events post-153049 tribe-clearfix tribe-events-venue-149976">
			
<div class="tribe-mini-calendar-event event--1 ">
	
	<div class="list-date">
					<span class="list-dayname">
				Jun			</span>
		
		<span class="list-daynumber">04</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="http://www.watermarkonline.com/event/lgbtq-loss-grief-support-group/2019-06-04/" rel="bookmark">LGBTQ Loss and Grief Support Group</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">June 4 @ 6:00 pm</span> - <span class="tribe-event-time">7:15 pm</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
							<div class="tribe-events-location tribe-section-s">
					<span class="tribe-events-venue"><a href="http://www.watermarkonline.com/venue/friendship-center/" title="Friendship Center">Friendship Center</a></span>
			
			
							<div>
											<span class="tribe-events-locality">Sarasota</span>
					
					
									</div>				</div>
			
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<!-- Event  -->
		<div class="type-tribe_events post-153050 tribe-clearfix tribe-events-venue-149976">
			
<div class="tribe-mini-calendar-event event--1 ">
	
	<div class="list-date">
					<span class="list-dayname">
				Jun			</span>
		
		<span class="list-daynumber">11</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="http://www.watermarkonline.com/event/lgbtq-loss-grief-support-group/2019-06-11/" rel="bookmark">LGBTQ Loss and Grief Support Group</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">June 11 @ 6:00 pm</span> - <span class="tribe-event-time">7:15 pm</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
							<div class="tribe-events-location tribe-section-s">
					<span class="tribe-events-venue"><a href="http://www.watermarkonline.com/venue/friendship-center/" title="Friendship Center">Friendship Center</a></span>
			
			
							<div>
											<span class="tribe-events-locality">Sarasota</span>
					
					
									</div>				</div>
			
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<p class="tribe-events-widget-link">
		<a href="http://www.watermarkonline.com/events/" rel="bookmark">
			View More&hellip;		</a>
	</p>
	
</div>
																			
																		</div><script type="application/ld+json">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</script><div id="bwp_recent_comments-3" class="sidebar_widget bwp-rc-widget">
																			
																			<div class="widget"><h3 class="widgettitle">Recent Comments</h3>
		<ul class="bwp-rc-ulist">
<li class="recent-comment"><span class="recent-comment-avatar"><img src="http://1.gravatar.com/avatar/d64e7e71fb84c39ef8a24a7a26d187fe?s=40&#038;d=mm&#038;r=g" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author"><a href="http://www.watermarkonline.com/2019/05/15/watermark-giveaway-tickets-to-see-pentatonix-w-rachel-platten-citizen-queen-at-orlandos-amway-center/#comment-12052">Chad</a></span><span class="recent-comment-text">Their cover of the Sound of Silence is amazing.</span> <a href="http://www.watermarkonline.com/2019/05/15/watermark-giveaway-tickets-to-see-pentatonix-w-rachel-platten-citizen-queen-at-orlandos-amway-center/#comment-12052" title="Comment on Watermark Giveaway: Tickets to see Pentatonix w/ Rachel Platten &amp; Citizen Queen at Orlando&#039;s Amway Center"><strong>May 21, 7:06 AM</strong></a></span></li>
<li class="recent-comment"><span class="recent-comment-avatar"><img src="http://1.gravatar.com/avatar/1cdcaa1a067a890013469d73ce1af9d0?s=40&#038;d=mm&#038;r=g" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author"><a href="http://www.watermarkonline.com/2019/05/15/watermark-giveaway-tickets-to-see-pentatonix-w-rachel-platten-citizen-queen-at-orlandos-amway-center/#comment-12051">Heath</a></span><span class="recent-comment-text">hallelujah</span> <a href="http://www.watermarkonline.com/2019/05/15/watermark-giveaway-tickets-to-see-pentatonix-w-rachel-platten-citizen-queen-at-orlandos-amway-center/#comment-12051" title="Comment on Watermark Giveaway: Tickets to see Pentatonix w/ Rachel Platten &amp; Citizen Queen at Orlando&#039;s Amway Center"><strong>May 19, 12:29 AM</strong></a></span></li>
<li class="recent-comment"><span class="recent-comment-avatar"><img src="http://0.gravatar.com/avatar/fe30ed63773dcfae1b65b410c9a785de?s=40&#038;d=mm&#038;r=g" width="40" height="40" alt="User Avatar" class="avatar avatar-40 wp-user-avatar wp-user-avatar-40 photo avatar-default" /></span><span class="recent-comment-single"><span class="recent-comment-author"><a href="http://www.watermarkonline.com/2019/05/16/05-15-19-tampa-bay-bureau-chiefs-desk/#comment-12050">Kathryn Nevets</a></span><span class="recent-comment-text">Such a great story. Thank you for sharing yours.</span> <a href="http://www.watermarkonline.com/2019/05/16/05-15-19-tampa-bay-bureau-chiefs-desk/#comment-12050" title="Comment on 05.15.19 Tampa Bay Bureau Chief&#039;s Desk"><strong>May 16, 3:40 PM</strong></a></span></li>
		</ul>
</div>
																			
																		</div><div id="adspeed-ad-server-3" class="sidebar_widget AdSpeed Ad Server">
																			
																			<div class="widget"><div class="AdSpeedWP">
		<!-- AdSpeed.com WP Ad Tag 8.0.2 for [Zone] #44238 [Any Dimension] -->
		<script type="text/javascript" src="//g.adspeed.net/ad.php?do=js&zid=44238&wd=-1&ht=-1&target=_blank&cb=1559052666"></script>
		<!-- AdSpeed.com End --></div></div>
																			
																		</div><div id="wpadverts-widget-categories-2" class="wmrk-recent-digitalpubs sidebar_widget wpadverts-widget-categories">
																			
																			<div class="widget"><h3 class="widgettitle">Classified Ads Categories</h3>        <div class="wpjb adverts-widget adverts-widget-categories">
            <div class="adverts-grid adverts-grid-compact">
                                                <div class="adverts-grid-row">
                    <div class="adverts-col-100">
                        <span>No categories found.</span>
                    </div>
                </div>
                 
            </div>
        </div>
        </div>
																			
																		</div><div id="custom_html-12" class="widget_text sidebar_widget widget_custom_html">
																			
																			<div class="widget_text widget"><h3 class="widgettitle">Specialty Publications</h3><div class="textwidget custom-html-widget"><div data-configid="3597836/69924267" style="width: 100%; height: 284px;" class="issuuembed"></div><script type="text/javascript" src="//e.issuu.com/embed.js" async="true"></script>
<div data-configid="3597836/65243684" style="width: 100%; height: 284px;" class="issuuembed"></div><script type="text/javascript" src="//e.issuu.com/embed.js" async="true"></script>
<div data-configid="3597836/69534501" style="width: 100%; height: 284px;" class="issuuembed"></div><script type="text/javascript" src="//e.issuu.com/embed.js" async="true"></script></div></div>
																			
																		</div><div id="nav_menu-2" class="sidebar_widget widget_nav_menu">
																			
																			<div class="widget"><h3 class="widgettitle">Resources</h3><div class="menu-resources-container"><ul id="menu-resources-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30011"><a href="http://www.watermarkonline.com/aboutcontact/">About/Contact</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29988"><a href="http://www.watermarkonline.com/category/digital-publication/">Digital Publications</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29990"><a href="http://www.watermarkonline.com/distribution-map/">Distribution Map</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29981"><a href="http://www.watermarkonline.com/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84796"><a href="http://www.watermarkonline.com/adverts/">Classified Adverts</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29983"><a href="http://www.watermarkonline.com/business-directory/">Business Directory</a></li>
</ul></div></div>
																			
																		</div><div id="wp_sidebarlogin-2" class="sidebar-login sidebar_widget widget_wp_sidebarlogin">
																			
																			<div class="widget"><h3 class="widgettitle">Login</h3>
		<form name="loginform" id="loginform" action="http://www.watermarkonline.com/wp-login.php" method="post">
			
			<p class="login-username">
				<label for="user_login">Username</label>
				<input type="text" name="log" id="user_login" class="input" value="" size="20" />
			</p>
			<p class="login-password">
				<label for="user_pass">Password</label>
				<input type="password" name="pwd" id="user_pass" class="input" value="" size="20" />
			</p>
			
			<p class="login-remember"><label><input name="rememberme" type="checkbox" id="rememberme" value="forever" checked="checked" /> Remember Me</label></p>
			<p class="login-submit">
				<input type="submit" name="wp-submit" id="wp-submit" class="button button-primary" value="Login &rarr;" />
				<input type="hidden" name="redirect_to" value="http://www.watermarkonline.com/2019/05/27/suspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt/" />
			</p>
			
		</form><ul class="pagenav sidebar_login_links"><li class="register-link"><a href="http://www.watermarkonline.com/wp-login.php?action=register">Register</a></li><li class="lost_password-link"><a href="http://www.watermarkonline.com/wp-login.php?action=lostpassword">Lost Password</a></li></ul></div>
																			
																		</div>                           
                            
                            
                            
                            
                            </div> 
               
                        </div>	 	
                        <!-- Sidebar Section ends here -->

                        <!-- Footer Sidebar Section starts here -->
               			                    
                                                <div id="footer_sidebar">
                
                                    <div id="footerwidgets">
                                        <div id="footerwidgetcontainer">
                                            <div class="footerwidget">
                                                                        
                                                    <div id="custom_html-5" class="widget_text widget widget_custom_html"><h3 class="widgettitle">About Us</h3><div class="textwidget custom-html-widget"><img src="http://www.watermarkonline.com/wp-content/uploads/2019/05/WatermarkPublishingGroup-DarkBackground.png" style="float:left; width:30%; margin:5px 5px 0 0;"> Watermark is a multi-faceted media company using opportunities and innovations to communicate and advance LGBT interests, with a corporate emphasis on professionalism while building strong relationships with our readers, customers and community.
<br><br>
Watermark Media was founded by Tom Dyer in Orlando in 1994, and expanded to Tampa Bay in 1995. Dyer is an attorney, former board member of the Metropolitan Business Association and Tampa International Gay & Lesbian Film Festival, and current advisory board member of the Harvey Milk Foundation.
<br><br>
Watermark prints up to 20,000 copies every other Thursday, and distributes them in more than 500 locations throughout Orlando, Tampa Bay, Sarasota and throughout the state. The newspaper donates more than $200,000 annually in free and sponsor advertising to worthy local and national LGBT non-profits.
<br><br>
Watermarkonline.com was launched in 1999. The award-winning newspaper currently maintains offices in Tampa Bay and Orlando and employs a full-time staff of 12, along with several part-time and freelance contributors.
<br><br>
Watermark Publishing Group, founded by publisher Rick Claggett, purchased Watermark in January of 2016.  Rick Claggett is a long-time employee of Watermark Media and former board member of both the Metropolitan Business Association and Come Out With Pride.<a href="aboutcontact">Read More...</a>
</div></div><div id="custom_html-6" class="widget_text widget widget_custom_html"><h3 class="widgettitle">Advertise</h3><div class="textwidget custom-html-widget"><a href="advertise" class="footer-ad-button">Click here</a> Grow your business!  Advertise with Watermark Publishing Group!
</div></div>                    
                                            </div>
                                        
                                            
                                        
                                            <div class="footerwidget">
                                                    <div id="custom_html-7" class="widget_text widget widget_custom_html"><h3 class="widgettitle">Send Us A News Tip</h3><div class="textwidget custom-html-widget">Have you got a hot news tip that you'd like to share with us? Simply fill out the form below and click submit!
<br><br>
<div role="form" class="wpcf7" id="wpcf7-f102365-o2" lang="en-US" dir="ltr">
<div class="screen-reader-response"></div>
<form action="/2019/05/27/suspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt/#wpcf7-f102365-o2" method="post" class="wpcf7-form" novalidate="novalidate">
<div style="display: none;">
<input type="hidden" name="_wpcf7" value="102365" />
<input type="hidden" name="_wpcf7_version" value="5.1.1" />
<input type="hidden" name="_wpcf7_locale" value="en_US" />
<input type="hidden" name="_wpcf7_unit_tag" value="wpcf7-f102365-o2" />
<input type="hidden" name="_wpcf7_container_post" value="0" />
<input type="hidden" name="g-recaptcha-response" value="" />
</div>
<p><label> Your Name (required)<br />
    <span class="wpcf7-form-control-wrap your-name"><input type="text" name="your-name" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-validates-as-required" aria-required="true" aria-invalid="false" /></span> </label></p>
<p><label> Your Email (required)<br />
    <span class="wpcf7-form-control-wrap your-email"><input type="email" name="your-email" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-email wpcf7-validates-as-required wpcf7-validates-as-email" aria-required="true" aria-invalid="false" /></span> </label></p>
<p><label> Subject<br />
    <span class="wpcf7-form-control-wrap your-subject"><input type="text" name="your-subject" value="" size="40" class="wpcf7-form-control wpcf7-text" aria-invalid="false" /></span> </label></p>
<p><label> Your Message<br />
    <span class="wpcf7-form-control-wrap your-message"><textarea name="your-message" cols="40" rows="10" class="wpcf7-form-control wpcf7-textarea" aria-invalid="false"></textarea></span> </label></p>

<p><input type="submit" value="Send" class="wpcf7-form-control wpcf7-submit" /></p>
<div class="wpcf7-response-output wpcf7-display-none"></div></form></div></div></div>                                            </div>				
                        
                                            
                                        
                                            <div class="footerwidget">
                                                                                <div id="nav_menu-3" class="widget widget_nav_menu"><h3 class="widgettitle">Content</h3><div class="menu-content-container"><ul id="menu-content" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29987"><a href="http://www.watermarkonline.com/category/news/">All News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29976"><a href="http://www.watermarkonline.com/category/news/orlando-1/">Orlando</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29975"><a href="http://www.watermarkonline.com/category/news/tampa-bay-lgbt-news/">Tampa Bay</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29977"><a href="http://www.watermarkonline.com/category/news/florida-lgbt-news/">State</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29974"><a href="http://www.watermarkonline.com/category/news/nation/">Nation</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29979"><a href="http://www.watermarkonline.com/category/news/world/">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30006"><a href="http://www.watermarkonline.com/category/features-1/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30007"><a href="http://www.watermarkonline.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56133"><a href="http://www.watermarkonline.com/category/photos/">Photos</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-86925"><a href="/events/">Events</a></li>
</ul></div></div><div id="nav_menu-4" class="widget widget_nav_menu"><h3 class="widgettitle">Resources</h3><div class="menu-resources-container"><ul id="menu-resources-2" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30011"><a href="http://www.watermarkonline.com/aboutcontact/">About/Contact</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29988"><a href="http://www.watermarkonline.com/category/digital-publication/">Digital Publications</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29990"><a href="http://www.watermarkonline.com/distribution-map/">Distribution Map</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29981"><a href="http://www.watermarkonline.com/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-84796"><a href="http://www.watermarkonline.com/adverts/">Classified Adverts</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29983"><a href="http://www.watermarkonline.com/business-directory/">Business Directory</a></li>
</ul></div></div>                                            </div>
                                        </div>				
                                    </div>
                                    
                        </div>		
                  		                        
                        <!-- Footer Sidebar Section ends here -->




                    </div>	
                    <!-- Inner Content Section ends here -->
                    
           			                </div>	
                <!-- Content Section ends here -->	
                
                <!-- Footer Section starts here -->
                <div id="footer_section">
                    
                    
                                            <div id="bottomfooterwidgetcontainer">
                                                <div class="bottomfooterwidgety">
                                                                                                            <div class="footerp"><!--&copy; All rights reserved.--></div>
                                                        <div class="footercredit"><!--Designed by Watermark Media<a href="http://www.themealley.com/">ThemeAlley.Com</a>--></div>
                                                                                                            							
<div class="seach_section">

									<form method="get" action="http://www.watermarkonline.com/">
									<fieldset>
										<p class="searchtext"><input type="text" onblur="if(this.value=='') this.value='Enter search query here...'" onfocus="if(this.value=='Enter search query here...') this.value=''" value="Enter search query here..." name="s" class="text" /></p>
										<p class="searchsub"><input class="submit" type="submit" value="Go" /></p>
									</fieldset>
									</form>
							</div>                                                                                                    </div>
    
                                                <div class="bottomfooterwidget">
                                                                                                            
                                                
                                                                                                    </div>                                        
                                            
                                                <div class="bottomfooterwidget">
                                                                                                            
                                                
                                                                                                    </div>				
                            
                                            
                                                <div class="bottomfooterwidget footer-03">
                                                                                                                                        
                                                
                                                                                                    </div>
                                            </div>	                
                    
                    
                    
                    
           
                 </div>	
                 <!-- Footer Section ends here -->	
                                                              
			</div>	
			<!-- Wrapper two ends here -->	
            
		</div>	
		<!-- Wrapper three ends here -->           
	</div>	
	<!-- Wrapper four ends here -->	            				
	</div>	
	<!-- Wrapper one ends here -->	


		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script>
    jQuery(document).ready(function () {
		jQuery.post('http://www.watermarkonline.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var s = document.createElement("script");
			s.type = "text/javascript";
			s.innerHTML = response;
			jQuery("head").append(s);
		});
    });
</script><script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};var tribe_system_info = {"sysinfo_optin_nonce":"d6ee8cde40","clipboard_btn_text":"Copy to clipboard","clipboard_copied_text":"System info copied","clipboard_fail_text":"Press \"Cmd + C\" to copy"};/* ]]> */ </script><link rel='stylesheet' id='yarppRelatedCss-css'  href='http://www.watermarkonline.com/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='yarpp-thumbnails-yarpp-thumbnail-css'  href='http://www.watermarkonline.com/wp-content/plugins/yet-another-related-posts-plugin/includes/styles_thumbnails.css.php?width=120&#038;height=120&#038;ver=4.4' type='text/css' media='all' />
<link rel='stylesheet' id='widget-calendar-pro-style-css'  href='http://www.watermarkonline.com/wp-content/plugins/events-calendar-pro/src/resources/css/widget-full.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='adverts-frontend-css'  href='http://www.watermarkonline.com/wp-content/plugins/wpadverts/assets/css/adverts-frontend.css?ver=1.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='adverts-icons-css'  href='http://www.watermarkonline.com/wp-content/plugins/wpadverts/assets/css/adverts-glyphs.css?ver=1' type='text/css' media='all' />
<script src='http://www.watermarkonline.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-before.js'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script src='http://www.watermarkonline.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-after.js'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-includes/js/backbone.min.js?ver=1.2.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpApiSettings = {"root":"http:\/\/www.watermarkonline.com\/wp-json\/","nonce":"4611342d92","versionString":"wp\/v2\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-includes/js/api-request.min.js?ver=5.0.3'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-includes/js/wp-api.min.js?ver=5.0.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/www.watermarkonline.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"watermarkonline"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"277933 http:\/\/www.watermarkonline.com\/?p=277933","disqusShortname":"watermarkonline","disqusTitle":"Suspect in Utah killing of LGBTQ rights advocate found in Idaho after 2-day manhunt","disqusUrl":"http:\/\/www.watermarkonline.com\/2019\/05\/27\/suspect-in-utah-killing-of-lgbtq-rights-advocate-found-in-idaho-after-2-day-manhunt\/","postId":"277933"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201922'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6Lft_IMUAAAAAOYl3AcqBSHPNXZDuM_C2IeCuFtP&#038;ver=3.0'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-includes/js/comment-reply.min.js?ver=5.0.3'></script>
<script type='text/javascript' src='http://www.watermarkonline.com/wp-includes/js/wp-embed.min.js?ver=5.0.3'></script>
<script type="text/javascript">
( function( grecaptcha, sitekey ) {

	var wpcf7recaptcha = {
		execute: function() {
			grecaptcha.execute(
				sitekey,
				{ action: 'homepage' }
			).then( function( token ) {
				var forms = document.getElementsByTagName( 'form' );

				for ( var i = 0; i < forms.length; i++ ) {
					var fields = forms[ i ].getElementsByTagName( 'input' );

					for ( var j = 0; j < fields.length; j++ ) {
						var field = fields[ j ];

						if ( 'g-recaptcha-response' === field.getAttribute( 'name' ) ) {
							field.setAttribute( 'value', token );
							break;
						}
					}
				}
			} );
		}
	};

	grecaptcha.ready( wpcf7recaptcha.execute );

	document.addEventListener( 'wpcf7submit', wpcf7recaptcha.execute, false );

} )( grecaptcha, '6Lft_IMUAAAAAOYl3AcqBSHPNXZDuM_C2IeCuFtP' );
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201922.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.2.1',blog:'47990731',post:'277933',tz:'-4',srv:'www.watermarkonline.com'} ]);
	_stq.push([ 'clickTrackerInit', '47990731', '277933' ]);
</script>
<style type="text/css"></style></body>
</html>							
								
									

							
								
									
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 128/212 objects using disk
Page Caching using disk: enhanced 
Fragment Caching 8/9 fragments using disk

Served from: www.watermarkonline.com @ 2019-05-28 10:11:08 by W3 Total Cache
-->